Vid test

Status
Not open for further replies.

Dave

Red Leader
Staff member
Site Supporter
Joined
Aug 8, 2001
Messages
62,608
attachment
 

Attachments

  • 31793.mp4
    8 MB · Views: 65

Dave

Red Leader
Staff member
Site Supporter
Joined
Aug 8, 2001
Messages
62,608
I have managed to work out what the issue is.
When a member uploads a video using the 'Insert Video' method then the video retains .mp4 in the link. However when a member uploads as an attachment the video link is referenced which cannot be viewed by browsers using the iOS (operating systems) on Apple products

As a test, the following are the same video but uploaded using the two different methods:

The 'Insert Video' method:

As an attachment:

I'll look into the software further to see if I can restrict mp4 uploads as attachments which should resolve the issue.




If the member uploads the video using 1588591637028.png when they write a post the video loads fully and is viewable on Safari, etc

However if they load it as an attachment using the 1588591657577.png button, the forum code adds a reference to the file and Safari can't read that ..


The two videos above are the same video but uploaded using the two different methods
 
Last edited:

Dave

Red Leader
Staff member
Site Supporter
Joined
Aug 8, 2001
Messages
62,608
attachment - default style
 

Attachments

  • 31793.mp4
    8 MB · Views: 14

Dave

Red Leader
Staff member
Site Supporter
Joined
Aug 8, 2001
Messages
62,608
The issue is when a member uses the 'Attach file' button to upload the video but then doesn't insert it into the post once it is uploaded.
What seems to happen is if it is not inserted the video is not moved into the relevant 'data' folder but remains sat in limbo as an attachment with a file reference that iOS cannot read.

Here is the before and after link using the 'Attach file' button on our forum, and then using the option to insert video:

Attach only: https://www.maggotdrowning.com/forums/attachments/31793-mp4.32279/

Attach and insert: https://www.maggotdrowning.com/forums/data/video/32/32280-6a67b45e0cd87682ef8b5cf9b9582158.mp4
 
Status
Not open for further replies.
Top