Poor Internet Connection

Arfer Mo

Regular member
Site Supporter
Joined
Aug 30, 2007
Messages
618
I changed my computer in October last year, everything worked perfectly. The internet connection on my PC is wireless and the provider is Plusnet. About three weeks ago the internet connection started to slow up and become intermittent. I've checked with Plusnet and they say everything is OK at their end. I've reset the router and reinstalled the internet boosters we use twice. The TV is connected from a booster by cable and works OK so does my wife's laptop and my phone when it picks up a WIFI signal.

It appears it's only my PC that's having problems. Any help or suggestions will be greatly appreciated.
 

Reg Prescott

Member
Joined
Jan 4, 2018
Messages
8
Can you try an ethernet cable from router to PC? If that works OK could be a problem with the wi-fi cord in the PC. Or maybe the router
 

The Landlord

Regular member
Site Supporter
Joined
Jul 26, 2018
Messages
4,813
Have you run all the usual checks on malware & viruses? Quite often, malware can be the cause of a slow pc. Also have a look at which processes are running all the time which are not needed.
 

Arfer Mo

Regular member
Site Supporter
Joined
Aug 30, 2007
Messages
618
Can you try an ethernet cable from router to PC? If that works OK could be a problem with the wi-fi cord in the PC. Or maybe the router
No, the router is downstairs, the PC is upstairs directly above the router.

Have you run all the usual checks on malware & viruses? Quite often, malware can be the cause of a slow pc. Also have a look at which processes are running all the time which are not needed.
Yes I've checked for malware etc using malwarebytes plus the usual checks carried out by Microsoft Edge.

How do I check which processes are running?
 

davepellet

Regular member
Joined
Jan 5, 2007
Messages
1,952
Is it a desktop style PC or a laptop?

desktops are notorious for bad wifi connectivity (well, older ones are... can't comment on new ones)
 

Arfer Mo

Regular member
Site Supporter
Joined
Aug 30, 2007
Messages
618
It's a desktop PC, five months old with two screw in aerials to pick up the
.
 

The Landlord

Regular member
Site Supporter
Joined
Jul 26, 2018
Messages
4,813
No, the router is downstairs, the PC is upstairs directly above the router.


Yes I've checked for malware etc using malwarebytes plus the usual checks carried out by Microsoft Edge.

How do I check which processes are running?
Right click on the taskbar & then click Task Manager
 

Chervil

Regular member
Site Supporter
Joined
Jun 1, 2017
Messages
5,932
Have you checked the WiFi speed in the room, and where the aerials are? I downloaded a checker on my phone from google play and the difference in some rooms was very noticeable.
I have just got rid of Plusnet, as over the last couple of months the Wi-Fi, was getting worse and worse in my man cave, where I watch TV. It was getting to the stage where the TV was pixilating so much, It was unwatchable, via firestick. It was fibre to cabinet, the cabinet being about half a mile away.
Luckily BT have just installed fibre in my street, so I changed to them (Plusnet are part of BT), with a full fibre package. So far I haven't had any problems.
 

Geoff P

The MOGerator
Staff member
Site Supporter
Joined
Dec 2, 2001
Messages
16,057
If you are running Windows Defender get rid of Malwarebytes.

My laptop was not running properly so I took it to a computer geek in Barnsley. He gave my laptop a complete health check and after calling me he uninstalled Avast and Malwarebytes and told me to just use Windows Defender as that does everything the other two programmes do and my laptop us running brilliantly.

All I do now is clear my browsing history every couple of days.
 

Arfer Mo

Regular member
Site Supporter
Joined
Aug 30, 2007
Messages
618
Have you checked the WiFi speed in the room, and where the aerials are? I downloaded a checker on my phone from google play and the difference in some rooms was very noticeable.
I've just installed a speed checker on my phone as suggested.

Speed by my PC. - Ping 11ms Download 39.85 Mbps Upload 18.93 Mbps

If you are running Windows Defender get rid of Malwarebytes.
I've followed your advice Geoff and removed Malwarebytes and Ccleaner

So far things seemed to have improved greatly. Thanks to all for the help and suggestions.
 

Arfer Mo

Regular member
Site Supporter
Joined
Aug 30, 2007
Messages
618
After initially thinking my internet speed had improved it deteriorated considerably and became erratic. I also changed my internet provider to BT and contacted the supplier I purchased the PC from they sent me a new wireless card for my PC. I fitted that today and things are back to normal.:D
 

John Step

Regular member
Site Supporter
Joined
Nov 29, 2016
Messages
1,046
Wife had AVG free and after about a year her laptop started running ridiculously slow. That coincided with requests for her to upgrade her security for payment of course.
I knocked that off and reverted to the one BT include in the internet price and hey presto, up to speed.
Am I being cynical?
 

MunchMyStump

Regular member
Site Supporter
Joined
Sep 22, 2020
Messages
795
I'm using a MiFi device for my internet. Connected to the 3 Network and I pay £20 per month for unlimited data. I can cancel at any time, no line rental and the speed is comparable to fibre. 25 Mbps on both upload and download.
 
Top